observable_locator 0.3.0 icon indicating copy to clipboard operation
observable_locator: ^0.3.0 copied to clipboard

A service locator that uses MobX for reactive dependencies

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add observable_locator

With Flutter:

 $ flutter pub add observable_locator

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  observable_locator: ^0.3.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:observable_locator/observable_locator.dart';
0
likes
110
pub points
2%
popularity

Publisher

shield icon for verified publishersblrobles.com

A service locator that uses MobX for reactive dependencies

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta, mobx

More

Packages that depend on observable_locator