objd 0.0.3
objd: ^0.0.3 copied to clipboard

outdated

objd is a Object Oriented framework for Building Minecraft Datapacks with ease

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add objd

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  objd: ^0.0.3

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:objd/basic/block.dart';
import 'package:objd/basic/command.dart';
import 'package:objd/basic/entity.dart';
import 'package:objd/basic/file.dart';
import 'package:objd/basic/for_list.dart';
import 'package:objd/basic/group.dart';
import 'package:objd/basic/pack.dart';
import 'package:objd/basic/text.dart';
import 'package:objd/basic/widget.dart';
import 'package:objd/build/build.dart';
import 'package:objd/build/create_project.dart';
import 'package:objd/build/io.dart';
import 'package:objd/core.dart';
import 'package:objd/objD/execute.dart';
import 'package:objd/objD/say.dart';
import 'package:objd/objD/setblock.dart';
import 'package:objd/objD/widgets.dart';
2
likes
0
pub points
57%
popularity

Publisher

stevertus.com

objd is a Object Oriented framework for Building Minecraft Datapacks with ease

Homepage

Documentation

Documentation

License

unknown (LICENSE)

Dependencies

colorize, meta

More

Packages that depend on objd