oauth_webauth 5.0.0+1 copy "oauth_webauth: ^5.0.0+1" to clipboard
oauth_webauth: ^5.0.0+1 copied to clipboard

This plugin provides an alternative to AppAuth using WebView for OAuth 2.0 authorization/authentication.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add oauth_webauth

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  oauth_webauth: ^5.0.0+1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:oauth_webauth/oauth_webauth.dart';
19
likes
90
pub points
84%
popularity

Publisher

unverified uploader

This plugin provides an alternative to AppAuth using WebView for OAuth 2.0 authorization/authentication.

Repository (GitHub)
View/report issues

Topics

#oauth #oauth2 #login #social-login

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, flutter_inappwebview, flutter_web_plugins, http, oauth2, shared_preferences

More

Packages that depend on oauth_webauth