oauth1 1.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 39

dart-oauth1 #

Build Status

"RFC 5849: The OAuth 1.0 Protocol" client implementation for dart

Usage #

Add to pubspec.yaml:

dependencies:
  oauth1: ^1.0.1

Please use like below.

import 'dart:io';
import 'package:oauth1/oauth1.dart' as oauth1;

void main() {
  // define platform (server)
  var platform = new oauth1.Platform(
      'https://api.twitter.com/oauth/request_token', // temporary credentials request
      'https://api.twitter.com/oauth/authorize',     // resource owner authorization
      'https://api.twitter.com/oauth/access_token',  // token credentials request
      oauth1.SignatureMethods.HMAC_SHA1              // signature method
      );

  // define client credentials (consumer keys)
  const String apiKey = 'LLDeVY0ySvjoOVmJ2XgBItvTV';
  const String apiSecret = 'JmEpkWXXmY7BYoQor5AyR84BD2BiN47GIBUPXn3bopZqodJ0MV';
  var clientCredentials = new oauth1.ClientCredentials(apiKey, apiSecret);

  // create Authorization object with client credentials and platform definition
  var auth = new oauth1.Authorization(clientCredentials, platform);

  // request temporary credentials (request tokens)
  auth.requestTemporaryCredentials('oob').then((res) {
    // redirect to authorization page
    print("Open with your browser: ${auth.getResourceOwnerAuthorizationURI(res.credentials.token)}");

    // get verifier (PIN)
    stdout.write("PIN: ");
    String verifier = stdin.readLineSync();

    // request token credentials (access tokens)
    return auth.requestTokenCredentials(res.credentials, verifier);
  }).then((res) {
    // yeah, you got token credentials
    // create Client object
    var client = new oauth1.Client(platform.signatureMethod, clientCredentials, res.credentials);

    // now you can access to protected resources via client
    client.get('https://api.twitter.com/1.1/statuses/home_timeline.json?count=1').then((res) {
      print(res.body);
    });

    // NOTE: you can get optional values from AuthorizationResponse object
    print("Your screen name is " + res.optionalParameters['screen_name']);
  });
}

In addition, You should save and load the granted token credentials from your drive. Of cource, you don't need to authorize when you did it.

1.0.1 #

  • Support Dart 2

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  oauth1: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:oauth1/oauth1.dart';
  
Version Uploaded Documentation Archive
1.0.4 Apr 7, 2019 Go to the documentation of oauth1 1.0.4 Download oauth1 1.0.4 archive
1.0.3 Sep 30, 2018 Go to the documentation of oauth1 1.0.3 Download oauth1 1.0.3 archive
1.0.2 Aug 11, 2018 Go to the documentation of oauth1 1.0.2 Download oauth1 1.0.2 archive
1.0.1 Jul 29, 2018 Go to the documentation of oauth1 1.0.1 Download oauth1 1.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
78
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
39
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.3.0.
 
 Because oauth1 depends on unittest >=0.2.8+2 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/src/authorization.dart.

Run dartfmt to format lib/src/authorization.dart.

Format lib/src/authorization_header.dart.

Run dartfmt to format lib/src/authorization_header.dart.

Format lib/src/authorization_header_builder.dart.

Run dartfmt to format lib/src/authorization_header_builder.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/authorization_response.dart (Run dartfmt to format lib/src/authorization_response.dart.)
  • lib/src/client.dart (Run dartfmt to format lib/src/client.dart.)
  • lib/src/credentials.dart (Run dartfmt to format lib/src/credentials.dart.)
  • lib/src/platform.dart (Run dartfmt to format lib/src/platform.dart.)
  • lib/src/signature_method.dart (Run dartfmt to format lib/src/signature_method.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and oauth1.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.58.0 <3.0.0