nova_utils 0.1.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 73

nova_utils 0.1.3 #

速诺flutter开发常用工具包 #

1.获取KV后台配置 #

NovaUtils.getConfigParams(String key) 
返回kv后台对应key的value值

2.检查更新 #

NovaUtils.checkUpdate(BuildContext context)

3.跳转应用市场 #

 NovaUtils.launchMarket({String iosUrl})

4.ios获取设置KeyChain #

NovaUtils.getKeyChainValue(List<String> paramsName)
NovaUtils.setKeyChanValue(Map<String, String> params)

0.1.2 #

  • TODO: Describe initial release.

android更新是通过对比本地的versionCode

ios 更新是通过对比本地的versionName

example/README.md

nova_utils_example #

Demonstrates how to use the nova_utils plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nova_utils: ^0.1.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nova_utils/nova_utils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
93
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Fix lib/update/ios_update_config.dart. (-3.45 points)

Analysis of lib/update/ios_update_config.dart reported 7 hints, including:

line 4 col 10: Name non-constant identifiers using lowerCamelCase.

line 5 col 10: Name non-constant identifiers using lowerCamelCase.

line 6 col 10: Name non-constant identifiers using lowerCamelCase.

line 7 col 10: Name non-constant identifiers using lowerCamelCase.

line 8 col 10: Name non-constant identifiers using lowerCamelCase.

Fix lib/update/android_update_config.dart. (-1.99 points)

Analysis of lib/update/android_update_config.dart reported 4 hints:

line 22 col 9: Name non-constant identifiers using lowerCamelCase.

line 46 col 7: Equality operator == invocation with references of unrelated types.

line 46 col 37: Avoid using unnecessary statements.

line 46 col 44: Avoid using unnecessary statements.

Fix lib/kv_utils.dart. (-1 points)

Analysis of lib/kv_utils.dart reported 2 hints:

line 97 col 10: Name non-constant identifiers using lowerCamelCase.

line 102 col 30: Name non-constant identifiers using lowerCamelCase.

Fix additional 4 files with analysis or formatting issues. (-1 points)

Additional issues in the following files:

  • lib/update/update_utils.dart (2 hints)
  • lib/generated/i18n.dart (Run flutter format to format lib/generated/i18n.dart.)
  • lib/nova_utils.dart (Run flutter format to format lib/nova_utils.dart.)
  • lib/update/android_update.dart (Run flutter format to format lib/update/android_update.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (package_info).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
crypto ^2.0.6 2.1.4
dio ^3.0.8 3.0.8
flutter 0.0.0
package_info 0.4.0+2 0.4.0+2 0.4.0+13
shared_preferences ^0.5.6 0.5.6
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
flutter_web_plugins 0.0.0
http_parser 3.1.3
meta 1.1.8
path 1.6.4
shared_preferences_macos 0.0.1+3
shared_preferences_platform_interface 1.0.1
shared_preferences_web 0.1.2+2
sky_engine 0.0.99
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test