notifications_enabled 0.0.2

notifications_enabled #

A Flutter plugin that checks from native side if push notifications are enabled.

Installation #

Declare a pubspec dependency in your Flutter project.

What is it for? #

It checks from native side if the app has permissions enabled/disabled for posting push notifications into user's device. In iOS it also provides information whether the permission was already requested.

How to use it? #

You can check the Example app to see a real use case on how to access the notifications enabled information. Shortly explained:

// Gets an optional checking if notifications are enabled for current app.
final Optional<bool> areNotificationsEnabled = await NotificationsEnabled.notificationsEnabled;

// Empty optional, means notification permissions were never requested
if (areNotificationsEnabled.isNotPresent) {
    // Possibly ask for permissions?
} else if (areNotificationsEnabled.value) {
    print('Notifications are enabled!');
} else {
    // Notiications are disabled
}

0.0.2 #

  • Upgrade quiver dependencies

0.0.1 #

  • Provide information regarding user's defined preferences regarding receiving push notifications

example/README.md

notifications_enabled_example #

Demonstrates how to use the notifications_enabled plugin.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  notifications_enabled: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:notifications_enabled/notifications_enabled.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
44
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/notifications_enabled.dart.

Run flutter format to format lib/notifications_enabled.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
quiver >=2.0.0 <3.0.0 2.0.3
Transitive dependencies
collection 1.14.11
matcher 0.12.5
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin