notepad_core_macos 1.4.2

  • Readme
  • Changelog
  • Installing
  • 44

notepad_core_macos #

A new flutter plugin project.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[1.4.2] - 2020-03-05 #

  • Notify ServiceState message with services

1.4.0 - 2020-02-26 #

  • Impl isBluetoothAvailable, BluetoothState notification
  • Impl startScan, stopScan, scanResultStream notification
  • Impl connect, disconnect, ConnectionState notification
  • Impl discoverServices, setNotifiable, requestMtu, requestConnectionPriority
  • Impl readValue, writeValue, inputValueStream notification

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  notepad_core_macos: ^1.4.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

No top-level libraries found

Cannot assign Flutter platform tags, because no .dart files were found in lib/

No top-level libraries found

Cannot assign runtime tags, because no .dart files where found in lib/

No top-level libraries found

Cannot assign sdk tags, because no .dart files where found in lib/

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: Documenting notepad_core_macos... Initialized dartdoc with 19 libraries in 26.0 seconds Validating docs... no issues found Documented 0 public libraries in 4.0 seconds stderr: Unhandled exception: dartdoc could not find any libraries to document #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:218:9)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test