nfc_reader 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

NFC Reader #

A new flutter plugin to help developers looking to use internal hardware inside Android devices for reading NFC tags.

Supported NFC Format #

PlatformSupported NFC Tags
AndroidNDEF
import 'package:nfc_reader/nfc_reader.dart';

How to use #

Android setup #

Add those two lines to your AndroidManifest.xml on the top

<uses-permission android:name="android.permission.NFC" />
<uses-feature
        android:name="android.hardware.nfc"
        android:required="true" />

For better details look at the demo app.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

0.0.1 #

  • First release, only for Android

1.0.0 #

  • Complete First release, added scan one tag, one time funcationality

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:nfc_reader/nfc_reader.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  NFCReadData _nfcReadData;

  StreamSubscription<NFCReadData> _streamSubscription;

  @override
  void initState() {
    super.initState();
  }

  @override
  void dispose() {
    super.dispose();
    _streamSubscription?.cancel();
  }

  void startReading() {
    StreamSubscription<NFCReadData> subscription =
        NfcReader.readNfc().listen((tag) {
      setState(() {
        _nfcReadData = tag;
      });
      print(_nfcReadData);
    }, onDone: () {
      setState(() {
        _streamSubscription = null;
      });
    });

    setState(() {
      _streamSubscription = subscription;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: Text('NFC READ EXAMPLE'),
        ),
        body: SafeArea(
          top: true,
          bottom: true,
          child: Center(
            child: ListView(
              children: <Widget>[
                Text(
                  _nfcReadData != null ? 'Id: ${_nfcReadData.oid}' : '',
                  textAlign: TextAlign.center,
                ),
                Text(
                  _nfcReadData != null ? 'Data: ${_nfcReadData.data}' : '',
                  textAlign: TextAlign.center,
                ),
                Text(
                  _nfcReadData != null
                      ? 'Status: ${_nfcReadData.currentStatus}'
                      : '',
                  textAlign: TextAlign.center,
                ),
                RaisedButton(
                  child: Text('Start NFC'),
                  onPressed: () {
                    startReading();
                  },
                ),
              ],
            ),
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nfc_reader: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nfc_reader/nfc_reader.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:nfc_reader/nfc_reader.dart]

Package does not support Flutter platform macos

Because of import path [package:nfc_reader/nfc_reader.dart]

Package does not support Flutter platform web

Because of import path [package:nfc_reader/nfc_reader.dart]

Package does not support Flutter platform windows

Because of import path [package:nfc_reader/nfc_reader.dart]

Package not compatible with SDK dart

because of import path [nfc_reader]

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test