nend_plugin 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 61

nend_plugin #

A Flutter plugin that bridging nendSDK.

Available ad formats #

  • Banner
  • Interstitial
  • Interstitial video
  • Rewarded video
  • Native

Supports #

TODO #

  • Fullscreen
  • Native video

0.0.4 #

  • Update Android module dependencies

0.0.3 #

  • Added support for native ad
  • Update Environment Flutter SDK version

0.0.2 #

  • Update Environment Flutter SDK version

0.0.1 #

  • Initial version

example/README.md

nend_plugin_example #

Demonstrates how to use the nend_plugin plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  nend_plugin: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:nend_plugin/nend_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
27
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Jan 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/interstitial.dart.

Run flutter format to format lib/interstitial.dart.

Format lib/interstitial_video.dart.

Run flutter format to format lib/interstitial_video.dart.

Format lib/native.dart.

Run flutter format to format lib/native.dart.

Format lib/rewarded_video.dart.

Run flutter format to format lib/rewarded_video.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8