navigation_dot_bar 0.1.3

  • Readme
  • Changelog
  • Installing
  • 71

Navigation Dot Bar #

Una libreria de Flutter, el cual agrega un BottomNavigationBar con un mejor estilo. Inspirada en la aplicacion "Reflectly"


Como usarlo #

Agregue la dependencia a su proyecto, editando el archivo pubspec.yaml.

    navigation_dot_bar: ^0.1.3

Importar la libreria a tu proyecto:

import 'package:navigation_dot_bar/navigation_dot_bar.dart';

Usalo de manera sencilla con BottomNavigationDotBar:

  appBar: AppBar( title: Text("Demo Bottom Navigation Bar")),
  body: Container(),
  bottomNavigationBar: BottomNavigationDotBar ( // Usar -> "BottomNavigationDotBar"
      items: <BottomNavigationDotBarItem>[
        BottomNavigationDotBarItem(icon:, onTap: () { /* Cualquier funcion - [abrir nueva venta] */ }),
        BottomNavigationDotBarItem(icon: Icons.alarm_add, onTap: () { /* Cualquier funcion - [abrir nueva venta] */ }),
        BottomNavigationDotBarItem(icon: Icons.timer, onTap: () { /* Cualquier funcion - [abrir nueva venta] */ }),

[0.1.2] #

  • Initial open source release

[0.1.3] #

  • Dynamic color

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  navigation_dot_bar: ^0.1.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:navigation_dot_bar/navigation_dot_bar.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [navigation_dot_bar] that is in a package requiring null.

Health suggestions

Format lib/navigation_dot_bar.dart.

Run flutter format to format lib/navigation_dot_bar.dart.

Maintenance suggestions

Package is getting outdated. (-58.63 points)

The package was last published 82 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and navigation_dot_bar.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies