navigation_bar 0.0.1

  • Readme
  • Changelog
  • Installing
  • 12

navigation_bar #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

##How to use ?

  1. Depend on it
  navigation_bar: "^0.0.1"
  1. Install it
$ flutter packages get
  1. Import it
import 'package:navigation_bar/navigation_tab_bar.dart';


class HomePage extends StatefulWidget {
  _HomePageState createState() => _HomePageState();

class _HomePageState extends State<HomePage> with TickerProviderStateMixin {
  void initState() {

  void dispose() {

  Widget build(BuildContext context) {
    var accentBackgroundColors = const Color(0xffe71d36);
    return new NavigationTabBar(
      onTap: (value, previousIndex) {},
      tabBuilder: (BuildContext context, int index) {
        return new LoginScreen();
      navigationViews: <NavigationPageView>[
        new NavigationPageView(
          icon: const Icon(Icons.home),
          title: '首页',
          color: const Color(0xffe71d36),
          vsync: this,
        new NavigationPageView(
          icon: const Icon(Icons.notifications),
          title: '卡包',
          color: accentBackgroundColors,
          vsync: this,
        new NavigationPageView(
          icon: const Icon(,
          title: '账户',
          color: accentBackgroundColors,
          vsync: this,

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  navigation_bar: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:navigation_bar/NavigationPageView.dart';
import 'package:navigation_bar/navigation_tab_bar.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.7.0.
 Because navigation_bar requires SDK version >=1.23.0 <2.3.0, version solving failed.

Maintenance issues and suggestions

Support future stable Dart 2 SDKs in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Package is getting outdated. (-45.48 points)

The package was last published 75 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and navigation_bar.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.3.0