native_pdf_viewer_plugin 0.0.4

Flutter Android iOS

A new flutter plugin project for Native PDF viewer.

PDF viewer for flutter #

Android and iOS working pdf viewer!

Use this package as a library #

Security #

  • Password protected pdf.

1. Depend on it #

Add this to your package's pubspec.yaml file:

dependencies:
  native_pdf_viewer_plugin: ^0.0.4

2. Install it #

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it #

Now in your Dart code, you can use:

import 'package:native_pdf_viewer_plugin/pdf_viewer_plugin.dart';
import 'package:native_pdf_viewer_plugin/pdf_viewer.dart';
import 'package:native_pdf_viewer_plugin/pdf_viewer_scaffold.dart';

4. Informations for Release on Android #

You have to follow first these steps: https://flutter.io/docs/deployment/android

0
likes
80
pub points
47%
popularity

A new flutter plugin project for Native PDF viewer.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

raju.bhusani@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on native_pdf_viewer_plugin