native_ads_flutter 1.0.7 icon indicating copy to clipboard operation
native_ads_flutter: ^1.0.7 copied to clipboard

Null Safety Native Full Ads and Native Banner Ads

TODO: Put a short description of the package here that helps potential users know whether this package might be useful for them.

Author #

PRAGNESH

Get started #

✔️ Native Ads Android
✔️ Native Ads IOS
✔️ Native Ads Banner
✔️ Native Ads Full

AdMOB only supports ads on mobile. Web and desktop are out of reach

✔️ Android
✔️ iOS

Getting started #

TODO: List prerequisites and provide or point to information on how to start using the package.

Getting started #

TODO: Add this to your package's pubspec.yaml file:

dependencies:
    native_ads_flutter: "<LATEST_VERSION>"

TODO: Install it - You can install packages from the command line:

flutter pub get

Android Specific Setup #

Update your AndroidManifest.xml app ads id #

Android: ca-app-pub-3940256099942544~3347511713
iOS: ca-app-pub-3940256099942544~1458002511
<manifest>
  <application>
    <meta-data
        android:name="com.google.android.gms.ads.APPLICATION_ID"
        android:value="ca-app-pub-3940256099942544~3347511713"/>
    </application>
</manifest>

iOS Specific Setup #

TODO: Update your Info.plist per Firebase instructions.

<key>GADApplicationIdentifier</key>
<string>ca-app-pub-3940256099942544~1458002511</string>
<key>io.flutter.embedded_views_preview</key>
<true/>

TODO Using Controller

final _controller = NativeAdmobController();

Show Native Ad #

Container(
  height: 330,
NativeAdmob(
    adUnitID: "<Your ad unit ID>",
    loading: Center(child: CircularProgressIndicator()),
    error: Text("Failed to load the ad"),
    controller: _controller,
    type: NativeAdmobType.full,
    options: NativeAdmobOptions(
    ratingColor: Colors.green,
// Others ...
    ),
  )
)
10
likes
80
pub points
56%
popularity

Publisher

unverified uploader

Null Safety Native Full Ads and Native Banner Ads

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on native_ads_flutter