my_complex 0.1.0

  • Readme
  • Changelog
  • Installing
  • 54

complex #

A library for Dart developers. It is awesome.

Usage #

A simple usage example:

import 'package:my_complex/my_complex.dart';

main() {
  var c = new Complex.cartesian(0,2);
  var p = new Complex.polar(2, math.PI/2);
  print(c.equals(p));
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.1 #

  • Initial version, fast Complex number library!

0.0.2 #

  • Changed equals functions to catch identity faster

0.0.3 #

  • Made some fields final
  • Corrected wrong path in README.md

0.0.4 #

  • Learned how to add documentation so that it appears on the pub
  • renamed "equal" to "similar"

0.1.0 #

  • compatibility with dart2

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  my_complex: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:my_complex/my_complex.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
44
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/src/complex_constants.dart. (-13.09 points)

Analysis of lib/src/complex_constants.dart reported 28 hints, including:

line 13 col 11: The declaration '_mod2' isn't referenced.

line 23 col 19: Unnecessary new keyword.

line 24 col 20: Unnecessary new keyword.

line 54 col 35: Unnecessary new keyword.

line 70 col 34: Unnecessary new keyword.

Fix lib/src/complex_polar.dart. (-7.71 points)

Analysis of lib/src/complex_polar.dart reported 16 hints, including:

line 13 col 11: The declaration '_mod2' isn't referenced.

line 25 col 12: Unnecessary new keyword.

line 38 col 7: Unnecessary new keyword.

line 41 col 34: Unnecessary new keyword.

line 46 col 34: Unnecessary new keyword.

Fix lib/src/complex_cartesian.dart. (-7.24 points)

Analysis of lib/src/complex_cartesian.dart reported 15 hints, including:

line 25 col 7: Unnecessary new keyword.

line 37 col 7: Unnecessary new keyword.

line 42 col 32: Unnecessary new keyword.

line 46 col 59: Unnecessary new keyword.

line 49 col 27: Unnecessary new keyword.

Fix lib/src/complex_base.dart. (-3.93 points)

Analysis of lib/src/complex_base.dart reported 8 hints, including:

line 10 col 29: Unnecessary new keyword.

line 11 col 30: Unnecessary new keyword.

line 12 col 35: Unnecessary new keyword.

line 13 col 28: Unnecessary new keyword.

line 14 col 33: Unnecessary new keyword.

Maintenance issues and suggestions

Fix analysis_options.yaml.

The analyzer can't parse analysis_options.yaml.

Package is getting outdated. (-55.89 points)

The package was last published 81 weeks ago.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and my_complex.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <3.0.0
Dev dependencies
test >=0.12.0 <2.0.0