more_builders 1.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 65

A simple package including "builder wrappers" for Rows, Columns and Wraps.

Adds the three new classes wich provide ListView.builder(..) and ListView.seperated(...) functionality to Columns, Rows and Wraps . All standard attributes can be passed through. Alternatively the plugin provides extensions on Row, Column and Wrap. As dart does currently not support factories in extensions you have call the extension on an actual instance of Row, Column or Wrap like this Row().builder(..).

Example #

final  List<String> items;

@override
Widget build(BuildContext context) {
    return BuilderRow(
	    itemNumber: items.length,
	    itemBuilder: (context, index){
		    return  Text(items[index]);
	    },
	    seperatorBuilder: (context, index){
		    return  VerticalDivider(width:  10,);
	    },
     );
}

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

[1.1.0] - Added Extensions #

example/main.dart

import 'package:flutter/material.dart';
import '../lib/more_builders.dart';
class Example extends StatelessWidget {
  const Example({Key key, @required this.items}) : super(key: key);
  final List<String> items;
  @override
  Widget build(BuildContext context) {
    return BuilderRow(
      itemNumber: items.length,
      itemBuilder: (context, index){
        return Text(items[index]);
      },
      seperatorBuilder: (context, index){
        return VerticalDivider(width: 10,);
      },
    );
  }
}

class ExampleWithExtensions extends StatelessWidget {
  const ExampleWithExtensions({Key key, @required this.items}) : super(key: key);
  final List<String> items;
  @override
  Widget build(BuildContext context) {
    return Row().builder(
      itemNumber: items.length,
      itemBuilder: (context, index){
        return Text(items[index]);
      },
      seperatorBuilder: (context, index){
        return VerticalDivider(width: 10,);
      },
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  more_builders: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:more_builders/more_builders.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • more_builders that is a package requiring null.

Health suggestions

Format lib/Extensions.dart.

Run flutter format to format lib/Extensions.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test