monkey2dart 1.0.0-alpha+1

  • Installing
  • Versions
  • 0

monkey2dart #

Compiles the Monkey programming language into equivalent Dart.

Still missing:

  • IfExpression
  • PrefixExpression
  • print is currently the only available built-in

Installation #

    monkey2dart: ^1.0.0-alpha

Then, in your command-line:

$ pub get

Usage #

Requires package:build_runner.

// tool/phases.dart
import 'package:build_runner/build_runner.dart';
import 'package:monkey2dart/build.dart';

final PhaseGroup phases = new PhaseGroup.singleAction(
    const Monkey2DartBuilder(),
    new InputSet('monkey_hello', const ['lib/*.monkey']));

// tool/build.dart
import 'package:build_runner/build_runner.dart';
import 'phases.dart';

main() => build(phases, deleteFilesByDefault: true);
$ dart tool/build.dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  monkey2dart: ^1.0.0-alpha+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:monkey2dart/monkey2dart.dart';
Version Uploaded Documentation Archive
1.0.0-alpha+1 Feb 5, 2017 Go to the documentation of monkey2dart 1.0.0-alpha+1 Download monkey2dart 1.0.0-alpha+1 archive
1.0.0-alpha Feb 5, 2017 Go to the documentation of monkey2dart 1.0.0-alpha Download monkey2dart 1.0.0-alpha archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.0