mongodb_mobile 0.0.7

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

mongodb_mobile #

A new flutter plugin project.

💚 💙 💜 Flutter MongoDB Mobile Plugin #

This project contains the source code for a plugin that enables Flutter apps to use the MongoDB Mobile embedded database. The example app included creates a database and a test collection and helps to load data.

At this point, the plugin supports Android Flutter apps. iOs app support coming soon! #

🧩🧩🧩 Up with MongoDB Mobile !! 🧩🧩🧩 #

0.0.1 #

  • Initial release

0.0.2 #

  • Added addToArray function

0.0.3 #

  • Removed @NotNull annotations causing runtime issue

0.0.4 #

  • Added mobile to atlas sync 🍎 🍎 🍎

0.0.5 #

  • 💙 Fixed query filter bug 💙

0.0.6 #

  • 💙 Added local query 💙

0.0.7 #

  • 🧩 Refactored addToArray and update functions 💙

example/README.md

mongodb_mobile_example #

Demonstrates how to use the mongodb_mobile plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mongodb_mobile: ^0.0.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mongodb_mobile/mongodb_mobile.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
43
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Nov 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
shared_preferences ^0.5.2+1 0.5.4+5
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test