modern_form_line_awesome_icons 2.0.1
modern_form_line_awesome_icons: ^2.0.1 copied to clipboard

Flutter plugin for the Line Awesome Icon pack as Flutter Icons widget.

line_awesome_icons #

Is a forked from line_awesome_icon for null-safety support

The Line Awesome Icon pack available as Flutter Icons

Getting Started #

This plugin is based on Line Awesome Icons pack, which you can use it as an IconData in Flutter project https://icons8.com/line-awesome/

Usage #

To use plugin, just import package import 'package:modern_form_line_awesome_icons/modern_form_line_awesome_icons.dart'; add use it as IconData in Icon widget:

Icon(LineAwesomeIcons.reddit, size: 60.0, color: Colors.redAccent))

Example #

import 'package:flutter/material.dart';
import 'package:modern_form_line_awesome_icons/modern_form_line_awesome_icons.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Icon(
            LineAwesomeIcons.reddit,
            size: 60.0,
            color: Colors.redAccent,
          ),
        ),
      ),
    );
  }
}
1
likes
110
pub points
56%
popularity

Publisher

appsauth.com

Flutter plugin for the Line Awesome Icon pack as Flutter Icons widget.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on modern_form_line_awesome_icons