mockable_filesystem 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

mockable_filesystem #

Provides a FileSystem factory class for allocating File, Directory and Link objects, with two implementations - one which in turn returns the real objects from dart:io, and one which returns mock versions. This allows tests to be written that make use of files and directories without having to create them on disk. The mock File/Directory/Link classes are not complete, but have sufficient functionality to work in most cases. The ultimate aim is to have complete mock implementations, as well as the ability to mock Windows file systems on Linux/Mac and vice-versa, to help with testing code for cross-platform correctness.

Installing #

  1. Depend on it

    Add this to your package's pubspec.yaml file:

    dependencies:
      mockable_filesystem: any
    

    If your package is an application package you should use any as the version constraint.

  2. Install it

    If you're using the Dart Editor, choose:

    Menu > Tools > Pub Install
    

    Or if you want to install from the command line, run:

    $ pub install
    
  3. Import it

    Now in your Dart code, you can use:

    import 'package:mockable_filesystem/filesystem.dart';
    

    or:

    import 'package:mockable_filesystem/mock_filesystem.dart';
    

0.0.3 #

  • Use FileSystemException in all appropriate places to follow the change to dart:io

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mockable_filesystem: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mockable_filesystem/filesystem.dart';
import 'package:mockable_filesystem/mock_filesystem.dart';
  
Version Uploaded Documentation Archive
0.0.3 Sep 23, 2014 Go to the documentation of mockable_filesystem 0.0.3 Download mockable_filesystem 0.0.3 archive
0.0.1 Jul 24, 2013 Go to the documentation of mockable_filesystem 0.0.1 Download mockable_filesystem 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.