mocha 0.0.2

  • Readme
  • Changelog
  • Installing
  • 0

mocha #

Mocha is a simple caching library for Dart.


  • Size-based eviction
  • Time-based expiration (since last write)
  • Asynchronously refresh values
  • Automatic asynchronous loading of values into the cache
  • Manually...
    • Evict/invalidate values
    • Populate the cache

Usage #

A simple usage example:

import 'dart:async';
import 'package:mocha/mocha.dart';

Future<String> expensiveOperation(int key) async {
  // pretend this is takes time to calculate
  var sq = key * key;
  return '$key^2 = $sq';

main() async {
  var cache = new LoadingCache<int, String>(
    maximumSize: 10,
    expiresAfterWrite: const Duration(minutes: 1)

  print(await cache.get(4));

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.2 #

  • Improved expiration (no timers)
  • Refresher -> Callable

0.0.1 #

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  mocha: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:mocha/mocha.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0