mobx_codegen 1.1.0+1

Dart native

Code generator for MobX that adds support for annotating your code with @observable, @computed, @action and also creating Store classes.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  mobx_codegen: ^1.1.0+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:mobx_codegen/mobx_codegen.dart';
72
likes
80
pub points
95%
popularity

Publisher

dart.pixelingene.com

Code generator for MobX that adds support for annotating your code with @observable, @computed, @action and also creating Store classes.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, build_resolvers, meta, mobx, path, source_gen

More

Packages that depend on mobx_codegen