mmkv_flutter 1.0.10

  • Readme
  • Changelog
  • Example
  • Installing
  • 86

mmkv_flutter #

Plugin that allow Flutter to read value from persistent storage or save value to persistent storage base on MMKV framework

Getting Started #

Open terminal, cd to your project directory, run pod repo update to make CocoaPods aware of the latest available MMKV versions

Quick Tutorial #


  MmkvFlutter mmkv = await MmkvFlutter.getInstance();

  mmkv.setBool('boolKey', true);
  print('get bool value is ${ await mmkv.getBool('boolKey')}');
  
  int counter = await mmkv.getInt('intKey') + 1;
  print('GetSetIntTest value is $counter ');
  await mmkv.setInt('intKey', counter);
  
  String stringtest = await mmkv.getString('stringKey') + '1';
  print('GetSetStringTest value is $stringtest');
  await mmkv.setString('stringKey', stringtest);

1.0.10 #

  • 第一个版本 与 MMKV 开源项目的版本号保持一致

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:mmkv_flutter/mmkv_flutter.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {

  _incrementCounter() async {
    MmkvFlutter mmkv = await MmkvFlutter.getInstance();
    int counter = await mmkv.getInt('intKey') + 1;
    print('GetSetIntTest is $counter ');
    await mmkv.setInt('intKey', counter);
  }

  _incrementString() async {
    MmkvFlutter mmkv = await MmkvFlutter.getInstance();
    String stringtest = await mmkv.getString('stringKey') + '1';
    print('GetSetStringTest is $stringtest');
    await mmkv.setString('stringKey', stringtest);
  }

  _setBool() async {
    MmkvFlutter mmkv = await MmkvFlutter.getInstance();
    mmkv.setBool('boolKey', true);
  }

  _getBool() async {
    MmkvFlutter mmkv = await MmkvFlutter.getInstance();
    print('get bool value is ${await mmkv.getBool('boolKey')}');
  }

  _clear() async {
    MmkvFlutter mmkv = await MmkvFlutter.getInstance();
    await mmkv.clear();
  }

  _setNullTest() async {
    MmkvFlutter mmkv = await MmkvFlutter.getInstance();
    await mmkv.setString('boolKey', null);
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        ),
        body: new Column(
          children: <Widget>[
            new RaisedButton(
              onPressed: _incrementCounter,
              child: new Text('GetSetIntTest'),
            ),
            new RaisedButton(
              onPressed: _incrementString,
              child: new Text('GetSetStringTest'),
            ),
            new RaisedButton(
              onPressed: _clear,
              child: new Text('clear'),
            ),
            new RaisedButton(
              onPressed: _getBool,
              child: new Text('GetBoolTest'),
            ),
            new RaisedButton(
              onPressed: _setBool,
              child: new Text('SetBoolTest'),
            ),
            new RaisedButton(
              onPressed: _setNullTest,
              child: new Text('SetNullTest'),
            )
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mmkv_flutter: ^1.0.10

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mmkv_flutter/mmkv_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
96
Overall:
Weighted score of the above. [more]
86
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/mmkv_flutter.dart.

Run flutter format to format lib/mmkv_flutter.dart.

Maintenance suggestions

Package is getting outdated. (-3.29 points)

The package was last published 53 weeks ago.

The package description is too short. (-1 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8