mjolnir 0.0.11

  • Readme
  • Changelog
  • Installing
  • 62

Mjolnir Dart #

Port of mjolnir-android to Dart. Abstraction layer for making network requests.

0.0.11 #

  • _id type for identifier fields

0.0.10 #

  • ignore more lint options for reals now

0.0.9 #

  • ignore some more lint options

0.0.8 #

  • make RequestBuilder.listOf work properly

0.0.7 #

  • allow setting custom client singleton

0.0.6 #

  • safe date time parsing

0.0.5 #

  • lint ignore rules

0.0.4 #

  • generated classes now have const constructor and all final fields

0.0.3 #

  • fix dartfmt bug

0.0.2 #

  • added flutter packages pub run mjolnir:codegen for automated code generation of domain classes

0.0.1 #

  • initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mjolnir: ^0.0.11

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mjolnir/mjolnir.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
89
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
53
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

142 out of 142 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/auth.dart. (-7.71 points)

Analysis of lib/src/auth.dart reported 16 hints, including:

line 3 col 10: Name non-constant identifiers using lowerCamelCase.

line 4 col 10: Name non-constant identifiers using lowerCamelCase.

line 5 col 7: Name non-constant identifiers using lowerCamelCase.

line 6 col 10: Name non-constant identifiers using lowerCamelCase.

line 10 col 10: Name non-constant identifiers using lowerCamelCase.

Fix lib/src/request_builder.dart. (-1.99 points)

Analysis of lib/src/request_builder.dart reported 4 hints:

line 20 col 10: Name non-constant identifiers using lowerCamelCase.

line 21 col 10: Name non-constant identifiers using lowerCamelCase.

line 32 col 10: Name non-constant identifiers using lowerCamelCase.

line 134 col 52: Name non-constant identifiers using lowerCamelCase.

Fix lib/src/request_compute.dart. (-1 points)

Analysis of lib/src/request_compute.dart reported 2 hints:

line 6 col 10: Name non-constant identifiers using lowerCamelCase.

line 7 col 10: Name non-constant identifiers using lowerCamelCase.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (dio).

The package description is too short. (-17 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and mjolnir.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
dio ^2.1.13 2.2.2 3.0.3
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
cookie_jar 1.0.1
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test