midiparser 1.1.1

  • README.md
  • Installing
  • Versions
  • 0

Midiparser #

This is a midiparser written dart.

Credit for the original methods and bit-shifting goes to Afandian, and his go-midi library

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate midiparser

2. Use it

The package has the following executables:


$ midiparser

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  midiparser: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:midiparser/midiparser.dart';
  
Version Uploaded Documentation Archive
1.1.1 Jan 15, 2017 Go to the documentation of midiparser 1.1.1 Download midiparser 1.1.1 archive
1.1.0 Jan 15, 2017 Go to the documentation of midiparser 1.1.0 Download midiparser 1.1.0 archive
1.0.3 Dec 11, 2016 Go to the documentation of midiparser 1.0.3 Download midiparser 1.0.3 archive
1.0.2 Dec 11, 2016 Go to the documentation of midiparser 1.0.2 Download midiparser 1.0.2 archive
1.0.1 Dec 11, 2016 Go to the documentation of midiparser 1.0.1 Download midiparser 1.0.1 archive
1.0.0 Dec 10, 2016 Go to the documentation of midiparser 1.0.0 Download midiparser 1.0.0 archive
0.1.1 Nov 24, 2016 Go to the documentation of midiparser 0.1.1 Download midiparser 0.1.1 archive
0.1.0 Nov 24, 2016 Go to the documentation of midiparser 0.1.0 Download midiparser 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.