mfchat 0.0.3

  • Readme
  • Changelog
  • Installing
  • 61

mfchat #

A new Flutter Chat package.

Usage 💻 #

To use this package, add mfchat as a dependency in your pubspec.yaml file.

API details 📝 #

See the mf_chat.dart for more API details

Issues and feedback 💭 #

If you have any suggestion for including a feature or if something doesn't work, feel free to open a Github issue for us to have a discussion on it.

[0.0.3] - TODO: Add release date. #

  • A customizable Chat package for flutter apps

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mfchat: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mfchat/mfchat.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • mfchat that is a package requiring null.

Health suggestions

Fix lib/mfchat.dart. (-1 points)

Analysis of lib/mfchat.dart reported 2 hints:

line 4 col 8: Unused import: 'package:flutter/services.dart'.

line 6 col 8: Unused import: 'package:flutter_parsed_text/flutter_parsed_text.dart'.

Fix lib/src/message_listview.dart. (-0.50 points)

Analysis of lib/src/message_listview.dart reported 1 hint:

line 25 col 11: The value of the local variable 'constraints' isn't used.

Format lib/src/chat_view.dart.

Run flutter format to format lib/src/chat_view.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and mfchat.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
flutter_parsed_text ^1.1.0 1.2.4
intl ^0.16.0 0.16.1
transparent_image ^1.0.0 1.0.0
uuid ^2.0.1 2.2.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
meta 1.1.8 1.2.2
path 1.7.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test