mfcc 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 61

version pub-version

A library to extract Mel-Frequency Cepstral Coefficients (MFCCs) from a signal.

Usage #

A simple usage example:

import 'package:mfcc/mfcc.dart';

main() {
  var sampleRate = 16000;
  var windowLength = 1024;
  var windowStride = 512;
  var fftSize = 512;
  var numFilter = 20;
  var numCoefs = 13;
  List<num> mySignal = // ...
  var features = MFCC.mfccFeats(mySignal, sampleRate, windowLength, windowStride, fftSize, numFilter, numCoefs);
  
}

Documentation #

Package documentation is available here. Generated using dartdoc.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

[Unreleased] #

[1.0.1] - 2020-01-31 #

Fixed #

  • Correct broken links and wrong method name in documentation.

[1.0.0] #

  • Initial version

example/mfcc_example.dart

import 'package:mfcc/mfcc.dart';

main() {
  var sampleRate = 16000;
  var windowLength = 1024;
  var windowStride = 512;
  var fftSize = 512;
  var numFilter = 20;
  var numCoefs = 13;
  var mySignal = List<double>.generate(16000, (i) => i.toDouble());
  var features = MFCC.mfccFeats(mySignal, sampleRate, windowLength, windowStride, fftSize, numFilter, numCoefs);
  print('Generated ${features.length} x ${features[0].length} MFCC features from signal of length ${mySignal.length}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mfcc: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mfcc/mfcc.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Health suggestions

Format lib/mfcc.dart.

Run dartfmt to format lib/mfcc.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
fft ^0.2.0 0.2.0
Transitive dependencies
matcher 0.12.8
meta 1.2.2 1.3.0-nullsafety
my_complex 0.1.0
path 1.7.0
quiver 2.1.3
stack_trace 1.9.5
tuple 1.0.3
Dev dependencies
pedantic ^1.8.0
test ^1.6.0