meta_types_json_generator 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 28

meta_types_json #

json mixin generation for meta_types

0.0.1 #

  • initial generator implementation

example/example.dart

/// See meta_types_redux example for code examples.
///
/// use `pub run build_runner build` to run the generator
///
/// make sure build_runner meta_types_generator, and meta_types_generator_json are
/// dev_dependencies in you pubspec.yaml

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  meta_types_json_generator: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:meta_types_json_generator/builder.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
92
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Feb 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/builder.dart. (-6.78 points)

Analysis of lib/builder.dart reported 14 hints, including:

line 9 col 5: Unnecessary new keyword.

line 9 col 28: Unnecessary new keyword.

line 14 col 20: Unnecessary new keyword.

line 126 col 7: DO use curly braces for all flow control structures.

line 128 col 7: DO use curly braces for all flow control structures.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (analyzer, build).

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/davidmarne/dart_meta_types/meta_types_json_generator was unreachable.

Package is getting outdated. (-55.89 points)

The package was last published 81 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2-0-0-dev <3.0.0
analyzer ^0.32.0 0.32.6 0.39.4
build ^0.12.0 0.12.8 1.2.2
meta ^1.0.0 1.1.8
meta_types ^0.1.0 0.1.0
meta_types_generator ^0.1.0 0.1.0
source_gen ^0.9.0 0.9.1+3 0.9.5
Transitive dependencies
args 1.5.2
async 2.4.0
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
dart_style 1.1.3 1.3.3
front_end 0.1.4+2 0.1.29
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
kernel 0.3.4+2 0.3.29
logging 0.11.4
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.9.1
path 1.6.4
pedantic 1.9.0
plugin 0.2.0+3
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0
Dev dependencies
build_runner ^0.9.0