meta 1.8.0 copy "meta: ^1.8.0" to clipboard
meta: ^1.8.0 copied to clipboard

outdated

Annotations used to express developer intentions that can't otherwise be deduced by statically analyzing source code.

pub package package publisher

This package defines annotations that can be used by the tools that are shipped with the Dart SDK.

Library Structure #

The annotations in this package are defined in two libraries.

The library in meta.dart defines annotations that can be used by static analysis tools to provide a more complete analysis of the code that uses them. Within the SDK, these tools include the command-line analyzer (dart analyze) and the analysis server that is used to power many of the Dart-enabled development tools.

The library in dart2js.dart defines annotations that provide hints to dart2js to improve the quality of the JavaScript code that it produces. These annotations are currently experimental and might be removed in a future version of this package.

Support #

Post issues and feature requests on the GitHub issue tracker.

Questions and discussions are welcome at the Dart Analyzer Discussion Group.

License #

See the LICENSE file.

417
likes
0
pub points
99%
popularity

Publisher

verified publisherdart.dev

Annotations used to express developer intentions that can't otherwise be deduced by statically analyzing source code.

Repository (GitHub)
View/report issues

License

unknown (license)

More

Packages that depend on meta