meta 1.3.0-nullsafety.4

Dart native js
Flutter Android iOS web

This library contains the declarations of annotations that developers can use to express the intentions that otherwise can't be deduced by statically analyzing the source code. These annotations are i

Annotations for Static Analysis #

This package defines annotations that can be used by the tools that are shipped with the Dart SDK.

Library Structure #

The annotations in this package are defined in two libraries.

The library in meta.dart defines annotations that can be used by static analysis tools to provide a more complete analysis of the code that uses them. Within the SDK, these tools include the command-line analyzer (dartanalyzer) and the analysis server that is used to power many of the Dart-enabled development tools.

The library in dart2js.dart defines annotations that provide hints to dart2js to improve the quality of the JavaScript code that it produces. These annotations are currently experimental and might be removed in a future version of this package.

Support #

Post issues and feature requests on the GitHub issue tracker.

Questions and discussions are welcome at the Dart Analyzer Discussion Group.

License #

See the LICENSE file.

107
likes
90
pub points
100%
popularity

Publisher

dart.dev

This library contains the declarations of annotations that developers can use to express the intentions that otherwise can't be deduced by statically analyzing the source code. These annotations are intended to be used by tools to provide a better user experience.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

More

Packages that depend on meta