meta 1.2.4
meta: ^1.2.4
meta: ^1.3.0-nullsafety.6

Dart native js
Flutter Android iOS web

This library contains the declarations of annotations that developers can use to express the intentions that otherwise can't be deduced by statically analyzing the source code. These annotations are i

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  meta: ^1.2.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:meta/meta.dart';
112
likes
80
pub points
100%
popularity

Publisher

dart.dev

This library contains the declarations of annotations that developers can use to express the intentions that otherwise can't be deduced by statically analyzing the source code. These annotations are intended to be used by tools to provide a better user experience.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

More

Packages that depend on meta