media_library 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 42

media_library #

Easy, flexible API for querying the media library on a device.

Features #

  • [ ] Images
    • [ ] List and filter images
      • [x] By limit/offset
      • [x] By date
      • [x] By time range
      • [ ] By EXIF tags
      • [ ] By location
  • [ ] Videos
  • [ ] Audio

0.0.1 #

  • Basic support for querying images.


media_library_example #

Demonstrates how to use the media_library plugin.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  media_library: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:media_library/media_library.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/src/channel.dart.

Run flutter format to format lib/src/channel.dart.

Format lib/src/library.dart.

Run flutter format to format lib/src/library.dart.

Format lib/src/models.dart.

Run flutter format to format lib/src/models.dart.

Format lib/src/query.dart.

Run flutter format to format lib/src/query.dart.

Format lib/src/widgets.dart.

Run flutter format to format lib/src/widgets.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field was unreachable.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (permission_handler).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
permission_handler ^3.0.0 3.3.0 4.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies