media_asset_utils 0.0.1 copy "media_asset_utils: ^0.0.1" to clipboard
media_asset_utils: ^0.0.1 copied to clipboard

outdated

A new flutter plugin project.

media_asset_utils #

Compress image/video as native plugin (Swift/Kotlin)

This library can works on Android and iOS.

写在前面 #

家境贫寒,工作繁忙。只能不定期更新,还望网友们见谅!

各平台最低要求

Android 21+

iOS 9.0+

项目描述 #

图片压缩使用 Luban (鲁班) —— 图片压缩工具,仿微信朋友圈压缩策略,不支持控制quality

视频压缩 使用硬件编码,并未使用ffmpeg

会根据quality对width、height进行自动缩放以及bitrate计算

bitrate计算公式 width * height * fps * 0.07

Native获取视频metadata

保存图片、视频到系统相册 支持Android Q

有点忙,没空写,未完 #

6
likes
0
pub points
43%
popularity

Publisher

unverified uploader

A new flutter plugin project.

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on media_asset_utils