measure 0.1.0-dev.3

  • Readme
  • Changelog
  • Installing
  • 61

measure #

A library for working with measurements, quantities and units.

This library is based on the javax.measure package.

Changelog #

0.1.0-dev.3 #

  • Support for dart 2
  • Remove dependency on package typedparser
  • move implementation of intValue to Measurable
  • rename constants to lower case versions
  • make unit constructors public
  • add unit converter const factories
  • computations with units
  • add units in quantity classes as static variables
  • rename Duration quantity to DurationQuantity to avoid collision with core Duration class
  • remove quantity type argument from Measure

0.0.1 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  measure: ^0.1.0-dev.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:measure/measure.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Jun 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and measure.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
collection ^1.14.0 1.14.12
intl >=0.15.0 <0.17.0 0.16.1
petitparser ^3.0.0 3.0.4
quiver >=0.24.0 <3.0.0 2.1.3
Transitive dependencies
matcher 0.12.6
meta 1.1.8
path 1.7.0
stack_trace 1.9.3
Dev dependencies
pedantic ^1.9.0
test >=0.12.0 <2.0.0