mdc 0.0.1

  • Example
  • Installing
  • Versions
  • 0

Material Components for the web (dart) #


import 'dart:html';

import 'package:mdc/mdc.dart' as mdc;

void main() {

  FormElement form = querySelector('#greeting-form');


void onSubmit(Event event) {
  String firstname = getInputValue('#firstname');
  String lastname = getInputValue('#lastname');

  String greeting = 'Hello';

  if (firstname.isNotEmpty || lastname.isNotEmpty) {
    greeting += ', ';

    if (firstname.isNotEmpty && lastname.isNotEmpty) {
      greeting += firstname + ' ' + lastname;
    } else if (lastname.isNotEmpty) {
      greeting += 'Mx. ' + lastname;
    } else {
      greeting += firstname;
  greeting += '!';

  ParagraphElement p = querySelector('#greeting');
  p.text = greeting;

String getInputValue(String selector) {
  InputElement input = querySelector(selector);
  return input.value;

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  mdc: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:mdc/mdc.dart';
Version Uploaded Documentation Archive
0.0.1 Dec 20, 2016 Go to the documentation of mdc 0.0.1 Download mdc 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0