md_to_html 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

md_to_html #

This is a simple transformer that converts all Markdown files into HTML based on a provided template.

To use, add md_to_html to your pubspec:

dependencies:
    md_to_html: ">=0.1.0 <0.2.0"

Then, add the transformer and set the template property to the location of a Mustache-style template:

transformers:
    md_to_html:
        template: "web/template.html"

In the template, the {{content}} tag will be replaced with the generated HTML from your Markdown. You can fill other tags by adding JSON to the beginning of your Markdown file.

For example:

{"title": "My Title"}

## This is a header

This is a paragraph.

With a template:

<html>
<head><title>{{title}}</title></head>
<body>{{content}}</body>
</html>

Would render as:

<html>
<head><title>My Title</title></head>
<body><h2>This is a header</h2>
<p>This is a paragraph.</p></body>
</html>

0.1.0 #

  • First release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  md_to_html: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:md_to_html/md_to_html.dart';
  
Version Uploaded Documentation Archive
0.1.0 Feb 13, 2015 Go to the documentation of md_to_html 0.1.0 Download md_to_html 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.