mathjax_view 0.1.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 69

mathjax_view #

Flutter Math Rendering Widget by MathJax.js

Install #

Add pubspec.yaml dependencies.

mathjax_view: ^0.1.0

then run the flutter packages get

Next, open ios/Runner.xcworkspace. Change Podfile like this

target 'Runner' do
  # Prepare symlinks folder. We use symlinks to avoid having Podfile.lock
  # referring to absolute paths on developers' machines.
  use_frameworks! # add this line

  system('rm -rf .symlinks')
  system('mkdir -p .symlinks/plugins')

and this

post_install do |installer|
  installer.pods_project.targets.each do |target|
    target.build_configurations.each do |config|
      config.build_settings['ENABLE_BITCODE'] = 'NO'
      config.build_settings['SWIFT_VERSION'] = '5.0' # add this line
    end
  end
end

Finally, move Info.plist, and add io.flutter.embedded_views_preview as Boolean, set the value to YES.

How to use #

This is simple widget, and you can set text and text size (px).

SizedBox(
  width: 300,
  height: 200,
  child: MathjaxView(
    onMathjaxViewCreated: _onMathjaxViewCreated,
    fontSize: 20,
  ),
),
...
void _onMathjaxViewCreated(MathjaxViewController _controller) {
  controller = _controller;
  controller.setLatexText(
      'This is set test \$4x - 2y\\frac{4}{2x}=0\$ <br /> 日本語もいける');
}

0.1.1 #

  • Remove loading view

0.0.10 #

  • Remove iOS line.

0.0.9 #

  • Add swift version attribute
  • Add Installation instruction.

0.0.1 #

  • Initial Release

example/README.md

mathjax_view_example #

Demonstrates how to use the mathjax_view plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mathjax_view: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mathjax_view/mathjax_view.dart';
  
Version Uploaded Documentation Archive
0.1.1 Jun 13, 2019 Go to the documentation of mathjax_view 0.1.1 Download mathjax_view 0.1.1 archive
0.1.0 Apr 8, 2019 Go to the documentation of mathjax_view 0.1.0 Download mathjax_view 0.1.0 archive
0.0.10 Apr 3, 2019 Go to the documentation of mathjax_view 0.0.10 Download mathjax_view 0.0.10 archive
0.0.9 Apr 2, 2019 Go to the documentation of mathjax_view 0.0.9 Download mathjax_view 0.0.9 archive
0.0.8 Mar 31, 2019 Go to the documentation of mathjax_view 0.0.8 Download mathjax_view 0.0.8 archive
0.0.7 Mar 31, 2019 Go to the documentation of mathjax_view 0.0.7 Download mathjax_view 0.0.7 archive
0.0.6 Mar 31, 2019 Go to the documentation of mathjax_view 0.0.6 Download mathjax_view 0.0.6 archive
0.0.5 Mar 31, 2019 Go to the documentation of mathjax_view 0.0.5 Download mathjax_view 0.0.5 archive
0.0.4 Mar 31, 2019 Go to the documentation of mathjax_view 0.0.4 Download mathjax_view 0.0.4 archive
0.0.3 Mar 31, 2019 Go to the documentation of mathjax_view 0.0.3 Download mathjax_view 0.0.3 archive

All 12 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

The package description is too short. (-10 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test