math_expressions 2.0.2
math_expressions: ^2.0.2 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

A library for parsing and evaluating mathematical expressions, supporting real numbers, vectors, and basic interval arithmetic.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  math_expressions: ^2.0.2

2. Install it

You can install packages from the command line:

with pub:

$ dart pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:math_expressions/math_expressions.dart';
65
likes
110
pub points
94%
popularity

Publisher

leonhardt.co.nz

A library for parsing and evaluating mathematical expressions, supporting real numbers, vectors, and basic interval arithmetic.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

vector_math

More

Packages that depend on math_expressions