math_evaluator 0.4.0

math_evaluator #

An interpreter for math expressions. Supports real and complex numbers.

Note: This library is still in an early state, the test coverage is not perfect, the performance is not optimized and some features are still unimplemented.

Usage #

var result = evaluate("1+sin(π/2)");
print(result); // prints "2"

TODO #

  • [x] Supporting complex numbers.
  • [ ] Increase test coverage and stability.

0.1.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  math_evaluator: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:math_evaluator/ast/complex.dart';
import 'package:math_evaluator/ast/contract/calculable.dart';
import 'package:math_evaluator/ast/contract/element.dart';
import 'package:math_evaluator/ast/contract/evaluable.dart';
import 'package:math_evaluator/ast/contract/literal.dart';
import 'package:math_evaluator/ast/contract/token.dart';
import 'package:math_evaluator/ast/degree.dart';
import 'package:math_evaluator/ast/difinition/constants.dart';
import 'package:math_evaluator/ast/difinition/functions.dart';
import 'package:math_evaluator/ast/difinition/operations.dart';
import 'package:math_evaluator/ast/func.dart';
import 'package:math_evaluator/ast/group.dart';
import 'package:math_evaluator/ast/identifier.dart';
import 'package:math_evaluator/ast/number.dart';
import 'package:math_evaluator/ast/operator.dart';
import 'package:math_evaluator/evalutaor.dart';
import 'package:math_evaluator/lex.dart';
import 'package:math_evaluator/parse.dart';
import 'package:math_evaluator/util.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.46.0 <2.0.0