mastodon_entities 1.1.10 copy "mastodon_entities: ^1.1.10" to clipboard
mastodon_entities: ^1.1.10 copied to clipboard

This package provides classes for working with Mastodon API entities in Dart.

pub.dev

Introduction #

This package provides classes for working with Mastodon API entities in Dart.

Features #

  • Handles all entity types defined in Mastodon API docs.
  • Provides serialization and deserialization methods for working with entities.

Installation #

Add Mastodon Entities as a dependency in your pubspec.yaml:

dependencies:
  mastodon_entities: ^1.1.10

Then, run dart pub get to install the package.

Usage #

To use Mastodon Entities in your application, simply import the package:

import 'package:mastodon_entities/mastodon_entities.dart';

Differences #

Mastodon Mastodon Entities
Context StatusContext
Error MastodonError
List UserList

License #

Mastodon Entities is BSD 3-Clause licensed.

Contributing #

Contributions are welcome! If you find a bug or want to add a new feature, please open an issue or submit a pull request.

0
likes
140
pub points
62%
popularity

Publisher

unverified uploader

This package provides classes for working with Mastodon API entities in Dart.

Repository (GitHub)
View/report issues

Topics

#mastodon #entities

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

freezed_annotation, json_annotation

More

Packages that depend on mastodon_entities