mapping_library_extentions 0.0.4

  • Readme
  • Changelog
  • Installing
  • 45

Mapping Library Extentions #

Mapping Library Native extention Methods and Classes. See the ' mapping_library ' for information. This library is part of the mapping_library but contains code specific for IOS and Android devices. It is only intended to be used together with the mapping_library.

For example of usage also see the example in the mapping_library package.

0.0.4 #

Format changes and small bugfixes

0.0.3 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mapping_library_extentions: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mapping_library_extentions/extentions.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
75
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Fix lib/src/widgets/OpenFlightMap.dart. (-0.50 points)

Analysis of lib/src/widgets/OpenFlightMap.dart reported 1 hint:

line 5 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: OpenFlightMap._mapView, OpenFlightMap.mapReady, OpenFlightMap.mapPositionChanged, OpenFlightMap.mapTabbed, OpenFlightMap._mapPosition

Fix lib/src/widgets/OsmMap.dart. (-0.50 points)

Analysis of lib/src/widgets/OsmMap.dart reported 1 hint:

line 5 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: OsmMap._mapView, OsmMap.mapReady, OsmMap.mapPositionChanged, OsmMap.mapTabbed, OsmMap._mapPosition

Format lib/extentions.dart.

Run flutter format to format lib/extentions.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and mapping_library_extentions.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
mapping_library ^0.0.4 0.0.6
sqflite ^1.1.7+1 1.3.0
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
http 0.12.0+4
http_parser 3.1.4
meta 1.1.8
path 1.6.4
pedantic 1.9.0
sky_engine 0.0.99
source_span 1.7.0
sqflite_common 1.0.0+1
string_scanner 1.0.5
synchronized 2.2.0
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test