lwdframework 0.4.0 icon indicating copy to clipboard operation
lwdframework: ^0.4.0 copied to clipboard

Lightweight Dart Framework is an api restful framework for dart and flutter developers.

LWD-Framework Lightweight Dart Framework is an api restful framework for dart and flutter developers.

import 'package:lwdframework/lwd.dart';
import 'package:lwdframework/lwdio.dart';

Future<void> main(List<String> arguments) async {
  final address = '127.0.0.1';
  const port = 4040;
  var router = LWDRouter();
  router.get('/greeting', (LWDRequest request) {
    return LWDResponse.ok('hello world!');
  });

  await LWDIO().server(router, address, port);
}

Installation #

download and install Dart. Dart SDK 2.14.0 or higher is required.

$ dart pub add lwdframework

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get): dependencies: lwdframework: ^0.1.0

1
likes
120
pub points
0%
popularity

Publisher

unverified uploader

Lightweight Dart Framework is an api restful framework for dart and flutter developers.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

http, logging, meta, path_to_regexp

More

Packages that depend on lwdframework