lookaround_iterator 1.0.1

  • README.md
  • Installing
  • Versions
  • 0

Dart lookaround iterator #

The LookaroundIterator class exposes a fixed number of elements in the past and future of the current iteration element.

// `it` is an iterator over a list of the numbers 1..10, currently
// pointing at `4`.
final it = new LookaroundIterator(
    new List.generate(10, (n) => n + 1).iterator,
    lookbehind: 2,
    lookahead: 3)

// Prints _2, 3, 4, 5, 6, 7_.
// Notice the negative start index and the inclusive range `<=`.
for (int i = -it.lookbehind; i <= it.lookahead; i++) {

Changelog #

1.0.1 #

  • Cosmetic changes to appease pana: Add analysis_options.yaml and CHANGELOG.md.
  • Fix strong_mode and linter warnings.
  • Update repository name in pubspec.yaml.

1.0.0 #

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  lookaround_iterator: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:lookaround_iterator/lookaround_iterator.dart';
Version Uploaded Documentation Archive
1.0.1+1 Nov 8, 2018 Go to the documentation of lookaround_iterator 1.0.1+1 Download lookaround_iterator 1.0.1+1 archive
1.0.1 Dec 6, 2017 Go to the documentation of lookaround_iterator 1.0.1 Download lookaround_iterator 1.0.1 archive
1.0.0 Aug 13, 2017 Go to the documentation of lookaround_iterator 1.0.0 Download lookaround_iterator 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.