logcat 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 83

logcat #

Flutter plugin to get system messages, stack traces etc and show them in app. Can also be used to get the app logs from a remote device with share plugin.

Call Logcat.exec() from anywhere to get logs as a Future String then use it in anyway within your app.

NOTE: This plugin fetches logs only on Android Devices presently.

Installation #

Add package to pubspec.yaml

logcat: ^1.0.2

Add Import

import 'package:logcat/logcat.dart';

Use it anywhere

Future<void> _getLogs() async {
    final String logs = await Logcat.execute();
    setState(() {
      // Update your UI
    });
  }

1.0.2 #

Added example

1.0.1 #

Bug fixes

1.0.0 #

Added docs

0.0.1 #

First Release

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';
import 'package:logcat/logcat.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _logs = 'Nothing yet';

  @override
  void initState() {
    super.initState();
    _getLogs();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Logcat Plugin example app'),
        ),
        body: SingleChildScrollView(
          child: Text(_logs),
        ),
      ),
    );
  }

  Future<void> _getLogs() async {
    final String logs = await Logcat.execute();
    setState(() {
      _logs = logs;
    });
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  logcat: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:logcat/logcat.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
83
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:logcat/logcat.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:logcat/logcat.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:logcat/logcat.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:logcat/logcat.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [logcat] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test