lodash_dart 0.0.2

Lodash #

Lodash is a Dart utility library delivering modularity, performance & extras.

[0.0.2] - Added array function.

  • Added chunk,drop and dropRight function.

example/main.dart

import 'package:flutter/material.dart';
import 'package:lodash_dart/lodash_dart.dart';

class HomePage extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: Center(
        child: FlatButton(
          child: Text("Test"),
          onPressed: () {
            Lodash _ = Lodash();
            List newData =
                _.chunk(array: [1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 23], size: 3);
            print(newData);
            //Output: [[1, 2, 3], [4, 5, 6], [7, 8, 9], [10, 23]]
          },
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lodash_dart: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lodash_dart/lodash_dart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Jul 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/lodash_dart.dart: Undefined name 'required' used as an annotation.

Health issues and suggestions

Fix lib/lodash_dart.dart. (-82.20 points)

Analysis of lib/lodash_dart.dart failed with 6 errors, including:

line 4 col 15: Undefined name 'required' used as an annotation.

line 4 col 37: Undefined name 'required' used as an annotation.

line 28 col 14: Undefined name 'required' used as an annotation.

line 28 col 36: Undefined name 'required' used as an annotation.

line 35 col 19: Undefined name 'required' used as an annotation.

Document public APIs. (-1 points)

6 out of 6 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/lodash_dart.dart: Undefined name 'required' used as an annotation.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/kadarsh11/lodash was unreachable.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin