loading_indicator_view 1.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 78

loading_indicator_view #

A collection of awesome flutter loading animation

Demo #

Usage #

loading_indicator_view: ^1.0.0

Animation types #

TypeTypeTypeType
1. LineSpinFadeLoader2. BallBeat3. BallClipRotateMultiple4. BallGridPulse
5. LineScale6. BallPulseRise7. BallScaleRippleMultiple8. BallZigZag
9. BallScale10. BallPulseSync11. BallScaleMultiple12. BallPulse
13. BallClipRotatePulse14. BallGridBeat15. SquareSpin16. BallSpinFadeLoader
17. BallScaleRipple18. SemiCircleSpin19. LineScalePulseOut20. BallClipRotate
21. Pacman22. BallRotate23. CubeTransition24. TriangleSkewSpin

Licence #

Copyright 2019 Hitomis, Inc.

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

    http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

1.1.0 #

  • 优化项目,去除无用代码,添加使用文档

1.0.0 #

  • 完成 24 个 loading widget

example/README.md

Example #

LineSpinFadeLoaderIndicator(); BallBeatIndicator(); BallClipRotateMultipleIndicator(); BallGridPulseIndicator(); LineScaleIndicator(); BallPulseRiseIndicator(); BallScaleRippleMultipleIndicator(); BallZigZagIndicator(); BallScaleIndicator(); BallPulseSyncIndicator(); BallScaleMultipleIndicator(); BallPulseIndicator(); BallClipRotatePulseIndicator(); BallGridBeatIndicator(); SquareSpinIndicator(); BallSpinFadeLoaderIndicator(); BallScaleRippleIndicator(); SemiCircleSpinIndicator(); LineScalePulseOutIndicator(); BallClipRotateIndicator(); PacmanIndicator(); BallRotateIndicator(); CubeTransitionIndicator(); TriangleSkewSpinIndicator();

details: example/lib/main.dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  loading_indicator_view: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:loading_indicator_view/loading_indicator_view.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/src/indicators/ball_pulse_sync_indicator.dart.

Run flutter format to format lib/src/indicators/ball_pulse_sync_indicator.dart.

Format lib/src/indicators/ball_rotate_indicator.dart.

Run flutter format to format lib/src/indicators/ball_rotate_indicator.dart.

Format lib/src/indicators/ball_scale_ripple_multiple_indicator.dart.

Run flutter format to format lib/src/indicators/ball_scale_ripple_multiple_indicator.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/indicators/ball_zig_zag_indicator.dart (Run flutter format to format lib/src/indicators/ball_zig_zag_indicator.dart.)
  • lib/src/indicators/line_scale_pulse_out_indicator.dart (Run flutter format to format lib/src/indicators/line_scale_pulse_out_indicator.dart.)
  • lib/src/indicators/triangle_skew_spin_indicator.dart (Run flutter format to format lib/src/indicators/triangle_skew_spin_indicator.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test