loading_dialog 0.0.1+1

  • Readme
  • Changelog
  • Installing
  • 75

loading_dialog #

A flutter widget of loading dialog.Easy to use.

Installing #

dependencies:
  loading_dialog: ^0.0.1 #latest version

or

dependencies:
  loading_dialog:
    git:
      url: "https://github.com/tianyu704/loading_dialog"

Getting Started #

Default

LoadingDialog loading = LoadingDialog(context);
loading.show();
loading.hide();

Your custom

LoadingDialog loadingDialog = LoadingDialog(
  buildContext: context,
  loadingView: null, //yourself loading view ,default is CircularProgressIndicator
  radius: 15, //dialog bg radius
  elevation: 0, //dialog elevation
  size: 50, // loading view size
  padding: 10, //text to loading view
  width: 150, //dialog width
  height: 150, //dialog height
  loadingMessage: "Loading...", //your message
  textColor: Colors.black54, //message text color
  textSize: 14,//message text size
  style: LoadingDialogStyle.horizontal, // or vertical
  backgroundColor: Colors.white, //dialog background color
  barrierColor: Colors.black54, //window color
  barrierDismissible: true, //touch window dismiss
);

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  loading_dialog: ^0.0.1+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:loading_dialog/loading_dialog.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
67
Overall:
Weighted score of the above. [more]
75
Learn more about scoring.

We analyzed this package on Dec 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-13 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and loading_dialog.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test