loading_card 0.0.5

Loading Card #

Displays a loading animation similar to when launching YouTube, where individual cards opacities fluctuate while loading data.

https://i.imgur.com/mgaOeGN.png

[0.0.1] - TODO: Add release date.

<<<<<<< HEAD

  • Initial release

[0.0.4] - TODO: Add release date.

  • Better documentation #

  • Initial release

[0.0.4] - TODO: Add release date.

  • Better documentation

b563af4e0d0c799980eb001763cc490441209f71

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:loading_card/loading_card.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: Text('Example Loading'),
        ),
        body: Center(
          // Can be placed alone or in a ListView builder
          child: ListView.builder(
              itemCount: 10,
              itemBuilder: (context, index) {
                return LoadingCard();
              }),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  loading_card: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:loading_card/loading_card.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/loading_card.dart.

Run flutter format to format lib/loading_card.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test