loading_card 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 61

Loading Card #

Displays a loading animation similar to when launching YouTube, where individual cards opacities fluctuate while loading data.


[0.0.1] - TODO: Add release date. #

<<<<<<< HEAD

  • Initial release

[0.0.4] - TODO: Add release date. #

  • Better documentation #

  • Initial release

[0.0.4] - TODO: Add release date. #

  • Better documentation



import 'package:flutter/material.dart';
import 'package:loading_card/loading_card.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: Text('Example Loading'),
        body: Center(
          // Can be placed alone or in a ListView builder
          child: ListView.builder(
              itemCount: 10,
              itemBuilder: (context, index) {
                return LoadingCard();

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  loading_card: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:loading_card/loading_card.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Format lib/loading_card.dart.

Run flutter format to format lib/loading_card.dart.

Maintenance suggestions

Package is getting outdated. (-61.37 points)

The package was last published 84 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies