loader 0.4.0

Flutter Android iOS web

Run asynchronous code before building your widget. Loader will rebuild your widget after the loading is complete.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  loader: ^0.4.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:loader/loader.dart';
2
likes
90
pub points
75%
popularity

Publisher

aligator.ir

Run asynchronous code before building your widget. Loader will rebuild your widget after the loading is complete.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter

More

Packages that depend on loader