lipsum 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 85

lipsum-dart #

Build Status Pub

A lorem ipsum text generator for Dart.

1.0.1 #

  • Increase SDK range to facilitate version transitions.

1.0.0+1 #

  • Correction of test script and other minor cleanups.

1.0.0 #

  • Initial version, derived from lorem-dart plugin.

example/example.dart

import 'package:lipsum/lipsum.dart' as lipsum;

main() {
  print("Generating random words: " + lipsum.createWord(numWords: 4));

  var sentence = lipsum.createSentence();

  print("\nGenerating a random sentence:\n\n" + sentence);

  var paragraph = lipsum.createParagraph();

  print("\nGenerating a random paragraph:\n\n" + paragraph);

  var text = lipsum.createText(numParagraphs: 3, numSentences: 5);

  print("\nGenerating a random text:\n\n" + text);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lipsum: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lipsum/lipsum.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jun 7, 2019 Go to the documentation of lipsum 1.0.1 Download lipsum 1.0.1 archive
1.0.0+1 Mar 11, 2019 Go to the documentation of lipsum 1.0.0+1 Download lipsum 1.0.0+1 archive
1.0.0 Mar 11, 2019 Go to the documentation of lipsum 1.0.0 Download lipsum 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
71
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:lipsum/lipsum.dart.

Health suggestions

Fix lib/src/lipsum.dart. (-1 points)

Analysis of lib/src/lipsum.dart reported 2 hints:

line 34 col 5: DO use curly braces for all flow control structures.

line 56 col 5: DO use curly braces for all flow control structures.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.3 <3.0.0
Dev dependencies
test any