line_awesome_flutter 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new65

line_awesome_flutter #

Icons library, based on Line Awesome Icons

The Line Awesome Icon pack available as Flutter Icons. Provides 1542 additional icons to use in your apps.

If you use the icons publicly, please link to https://icons8.com/line-awesome somewhere on your page or artwork, so that more creators could know about it and use it for free.

Installing #

Include line_awesome_flutter in your pubspec.yaml file:

dependencies:
  flutter:
    sdk: flutter
  line_awesome_flutter: ^1.0

If your IDE doesn't do it automatically, type:

flutter packages get

Using #

Import the package in your dart file and use Icon to get the actual icon widget:

import 'package:line_awesome_flutter/line_awesome_flutter.dart';
...
Icon _icon = Icon(LineAwesomeIcons.home);
...

Credits #

1.0.1 #

  • bugfix: Correct package name param for IconData to match package name

1.0.0 #

  • Created LineAwesomeIcons class, which provides static access to all Line Awesome Icons as IconData, similar to Flutter's built-in Icons class.
  • Created README with installation instructions
  • Added LICENSE.md file

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:line_awesome_flutter/line_awesome_flutter.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
        theme: ThemeData(
          primarySwatch: Colors.blue,
        ),
        home: Scaffold(
          appBar: AppBar(
            title: Text("Line Awesome Icons Demo"),
          ),
          body: Center(child: Icon(LineAwesomeIcons.home)),
        ));
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  line_awesome_flutter: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:line_awesome_flutter/line_awesome_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
31
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-1 points)

1544 out of 1544 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test